1.0.57 - 2022.2.1 compatibility


  • GMLive’s API was updated to match current stable version of GMS2.
    I hope to release a separate tool for updating the API script automatically soon, but it may take time due to the overall situation in Ukraine.
  • Added support for #RrGgBb literals.
  • Added support for null-coalescing (??, ??=) operators.
  • Fixed a non-included trace function being called to show a warning when trying to live-load a room with a path layer.

P.S.: I’m unable to upload a Marketplace release in the new IDE version for unidentifiable reasons (pictured).

Files

GMLiveForGMS2.3+.yymps 852 kB
Version 1.0.57 Mar 11, 2022

Get GMLive.gml

Buy Now$29.95 USD or more

Comments

Log in with itch.io to leave a comment.

(1 edit)

Thanks so kindly for patching this. What’s the best method to update for license holders who purchased via the YoYo Market place? This is the error that I get when loading in the latest GMS2 version;

https://itch.io/post/5503144

GMLive is now updating correctly via the Market Place. You’re all legends!

Thank you for this update, was really waiting on this. Stay safe please Yellow!